Elevated API Errors

Incident Report for BigTime Software

Resolved

All systems are operational.
Posted Aug 11, 2026 - 14:30 CDT

Update

We have taken several steps to remediate the latency and high error rates experienced yesterday. We are continuing to monitor all systems throughout the day.
Posted Aug 11, 2026 - 08:03 CDT

Monitoring

We have identified and fixed an issue with one of our web servers that was causing a significant amount of errors, blocking users ability to login and perform certain actions. Performance has returned to normal but we will continue to monitor overnight and into morning. There are still several software fixes planned to release ASAP to ensure performance does not degrade again.
Posted Aug 10, 2026 - 18:16 CDT

Update

We are continuing to experience system load issues that are again impacting login for some users, preventing them from accessing the system.

Our team has identified several likely contributing areas and is actively working on fixes. We will deploy those fixes as soon as they have been tested and confirmed safe.
Posted Aug 10, 2026 - 17:38 CDT

Update

We are continuing to investigate performance degradation and high error rates in BigTime Delivery.
Posted Aug 10, 2026 - 16:49 CDT

Update

We are aware of a brief interruption to logins to BigTime Delivery; this has been resolved.
We are continuing to investigate performance degradation and high error rates in BigTime Delivery.
Posted Aug 10, 2026 - 14:07 CDT

Update

We are continuing to investigate performance degradation and high error rate in BigTime Delivery.
Posted Aug 10, 2026 - 12:05 CDT

Investigating

We are investigating issues with degraded performance and high error rates in Bigtime Delivery.
Posted Aug 10, 2026 - 11:08 CDT
This incident affected: BigTime Login, BigTime Delivery, and API v3.